I wrote it wrong.

Not gcc --version:7.7.0 but gcc--version : 7.3.0

($ gcc --version
gcc (GCC) 7.3.0
Copyright (C) 2017 Free Software Foundation, Inc.)

I will try a different complier.