Not sure, but these version numbers in your post don't match--
Code:
export PATH=./:~/GCC-7.3.0/bin/:$PATH

gcc --version : 7.7.0

The error could be related to the compiler support for OpenMP threads, so I would probably try a different compiler. It is not an error I've seen before, but I tend to use the Intel suite more than GCC.


Rick Venable
computational chemist