Previous Thread
Next Thread
Print Thread
Installing charmm45 with GAMESS-UK interface
#38228 03/25/21 11:57 AM
Joined: Mar 2021
Posts: 4
M
moth Offline OP
Forum Member
OP Offline
Forum Member
M
Joined: Mar 2021
Posts: 4
I'm trying to install the latest free version of charmm (45b2) interfaced to GAMESS-UK on Red Hat linux, but I run into some issues.
First off, the fact that you have to use install.com which is deprecated is concerning, but more problematically there is no makefile generated for GAMESS-UK in the build directory.
Running (with gcc 4.8.5)
Code
./install.com gnu U
or with PGI version 16.7 or 19.7
Code
./install.com gnu PGF95 U
to link GAMESS-UK, we just get the error
Code
make: guk.mk: No such file or directory
make: *** No rule to make target `guk.mk'.  Stop.
because there is no guk.mk file generated.

All the documentation I can find on the CHARMM/GAMESS-UK interface is fairly old, so I was wondering if anyone has any knowledge about the current state of the interface, or if I am perhaps missing something obvious?

I have followed the instructions, in terms of setting up the GAMESS-UK directory and charmm_configure etc., but the build doesn't even get far enough for that to be the trouble!

Cheers.

Re: Installing charmm45 with GAMESS-UK interface
moth #38241 03/30/21 07:36 AM
Joined: Mar 2021
Posts: 4
M
moth Offline OP
Forum Member
OP Offline
Forum Member
M
Joined: Mar 2021
Posts: 4
Hello again. I now have access to the full version of CHARMM45b2, but exactly the same issue is encountered here too. Any suggestions on whether this is possible to fix will be gratefully received.

Cheers.

Re: Installing charmm45 with GAMESS-UK interface
moth #38242 03/30/21 04:04 PM
Joined: Sep 2003
Posts: 175
Forum Member
Offline
Forum Member
Joined: Sep 2003
Posts: 175
You also need GAMESS-UK for which I don't know how old the version is (they stopped the development a while ago!) and if it still compiles with the new versions of fortran? But if you can successfully compile GAMESS-UK as standalone program we maybe able to help...

Last edited by milan; 03/30/21 04:08 PM. Reason: fix text
Re: Installing charmm45 with GAMESS-UK interface
moth #38243 03/31/21 12:01 PM
Joined: Mar 2021
Posts: 4
M
moth Offline OP
Forum Member
OP Offline
Forum Member
M
Joined: Mar 2021
Posts: 4
Yes, I can compile a version of GAMESS-UK with PGI16 (which is new compared to GAMESS-UK at least...). GAMESS-UK itself compiles and runs fine on its own.

Re: Installing charmm45 with GAMESS-UK interface
moth #38244 03/31/21 02:00 PM
Joined: Sep 2003
Posts: 175
Forum Member
Offline
Forum Member
Joined: Sep 2003
Posts: 175
I wanted to download the latest version of GAMESS-UK (so we have something that is the same) and there is no download button. Where did you get the sources?

Re: Installing charmm45 with GAMESS-UK interface
moth #38245 03/31/21 03:25 PM
Joined: Sep 2003
Posts: 8,556
Likes: 6
rmv Online Content
Forum Member
Online Content
Forum Member
Joined: Sep 2003
Posts: 8,556
Likes: 6
The PGI compiler has been problematic for compiling CHARMM, and it is usually best to use the same compiler when including external packages with CHARMM.

Is there something specific about GAMESS-UK that is of interest? There are other QM codes that are known to work with recent CHARMM versions.


Rick Venable
computational chemist

Re: Installing charmm45 with GAMESS-UK interface
moth #38246 04/01/21 07:41 AM
Joined: Mar 2021
Posts: 4
M
moth Offline OP
Forum Member
OP Offline
Forum Member
M
Joined: Mar 2021
Posts: 4
@milan I inherited version 7 from our group/lab when I joined. So I didn't have to contact CFS, which looks like the only listed way of getting the software now?

@rmv Yes, the tools I'm working on are unfortunately linked with GAMESS-UK (which might just mean we're doomed from the start), which is why I'm keen to get it included if possible. And these use PGI to compile, so as you point out I do need to compile CHARMM with PGI as well.

If the short answer is that pursuing GAMESS-UK with CHARMM is a bad idea (also considering the longer term) then that is also something useful to know.


Moderated by  lennart, rmv 

Link Copied to Clipboard
Powered by UBB.threads™ PHP Forum Software 7.7.4
(Release build 20200307)
Responsive Width:

PHP: 5.6.33-0+deb8u1 Page Time: 0.013s Queries: 28 (0.006s) Memory: 0.9433 MB (Peak: 1.0493 MB) Data Comp: Off Server Time: 2021-08-05 22:23:23 UTC
Valid HTML 5 and Valid CSS