CHARMM Development Project
Posted By: JohnPenniston MCMA - 04/19/06 05:25 PM
I am trying to run the test file ~/c32b1/c32test/mcmatest.inp . When I try this, it runs but it tests whether ?MCMA .ne. 1. It determines that ?MCMA is not equal to 1 and doesn't run the test. I tried commenting out the test of ?MCMA. When I did that, I got further, but then Charmm did not recognize the MCMA INIT command.

I have run some of the other tests without any problems. Can anyone advise me on how to get MCMA to work?
Posted By: lennart Re: MCMA - 04/19/06 05:41 PM
Add MCMA to pref.dat and reinstall, then try again. The if-test in the testcase simply checks whether this module was included in the installation.
Posted By: JohnPenniston Re: MCMA - 04/20/06 01:42 PM
Thanks; I thought maybe that was the case, so I had already done exactly what you said, but it didn't change the behavior. Somehow MCMA isn't getting set up right even though it should be.
Posted By: lennart Re: MCMA - 04/20/06 02:27 PM
Did you simply add MCMA to pref.dat and then issue the, or did you also remove the files that have to be removed before a re-installation (see one of the first posts in the Installation and performance forum for more info)?
Posted By: JohnPenniston Re: MCMA - 04/25/06 03:07 PM
Thanks! I removed the entire ~/exec and /lib folders, then ran It took a long time, but I was then able to run mcmatest.inp
Posted By: Rashid III Re: MCMA - 06/29/16 10:07 AM
Hi, I am experiencing the same problem. After adding 'MCMA' to build/gnu/pref.dat, I tried doing what John did (removig exec and lib). Problem is does not produce the charmm executable afterwards. I also tried deleting build/gnu/Makefile_gnu and build/gnu/Makefile (as suggested in the thread on reinstallation), but the charmm executable is still not produced.

Can someone help me please?
Posted By: lennart Re: MCMA - 06/29/16 11:01 AM
So what is the error message? See build/gnu/gnu.log
Try the following in a newly unpacked charmm tree: gnu +MCMA
Posted By: Rashid III Re: MCMA - 06/29/16 02:06 PM
That worked perfectly. Thank you very much! 😊

Didn't need a newly unpacked tree. Just removed build/gnu, exec, and lib.
Posted By: KVandy Re: MCMA - 07/05/22 04:25 PM

I am pretty new to CHARMM and am trying to get a simulation using MCMA running and have not been able to get CHARMM to recognize the MCMA command. I am running CHARMM on Ubuntu and have tried (based on the above suggestions) re-extracting the CHARMM download file and adding MCMA into the pref.dat file before running the configure, make, and install commands. Still after trying this when I attempt to run my CHARMM script it terminates saying "Unrecognized command: MCMA". I am wondering if there is something I am missing or if anyone can help me figure out how to get MCMA running. Thanks!
Posted By: rmv Re: MCMA - 07/05/22 07:56 PM
The installation procedure has changed since the posts above were written, and the correct method is shown as the output from './configure --help'.

In brief, the MCMA keyword must be added via the configure step, using the -a (or --add) option prior to compiling, with the syntax:
-a <keyword1,keyword2,...,keywordN>, --add <keyword1,keyword2,...,keywordN> 
         add the keywords to the final pref.dat
Posted By: KVandy Re: MCMA - 07/05/22 08:42 PM
Thank you!
© CHARMM forums