CHARMM Development Project
Posted By: protein Cannot work in parallel with mpi - 08/21/20 02:12 AM
I have installed charmm c45b1 with cmake successfully, but when running with mpirun, it prints the same result for mutiple times. I have also tried with srun, but it won't work in parallel either. Details are as below.

Run with: mpirun -n 4 /gpfs/user/tanyuhao/software/charmm_c45b1/bin/charmm -i ./sexampleout/energy_mutabinds_lb38p.inp path=./sexampleout protname=mutabinds > ./sexampleout/energy.test.out
Input and output are attached as energy_mutabinds_lb38p.txt and energe.test.txt
I am not familiar with the script, but it seems that PRNLEV or WRNLEV are not in it.

I have checked the version of compiler, and assume that charmm and mpi are compiled with the same compiler. Details are as below.
ldd /gpfs/user/tanyuhao/software/charmm_c45b1/bin/charmm => (0x00007ffc85f3e000)
/preload (0x00007ff520d92000) => /opt/intel/compilers_and_libraries_2018.1.163/linux/mpi/intel64/lib/ (0x00007ff5209e9000) => /opt/intel/compilers_and_libraries_2018.1.163/linux/mpi/intel64/lib/ (0x00007ff51fd64000) => /lib64/ (0x00007ff51fb60000) => /lib64/ (0x00007ff51f958000) => /lib64/ (0x00007ff51f73c000) => /opt/intel/compilers_and_libraries_2018.1.163/linux/mkl/lib/intel64_lin/ (0x00007ff51ec56000) => /opt/intel/compilers_and_libraries_2018.1.163/linux/mkl/lib/intel64_lin/ (0x00007ff51d948000) => /opt/intel/compilers_and_libraries_2018.1.163/linux/mkl/lib/intel64_lin/ (0x00007ff51b7b5000) => /lib64/ (0x00007ff51b493000) => /lib64/ (0x00007ff51b191000) => /lib64/ (0x00007ff51ae89000) => /lib64/ (0x00007ff51ac63000) => /lib64/ (0x00007ff51aa4d000) => /lib64/ (0x00007ff51a811000) => /lib64/ (0x00007ff51a444000)
/lib64/ (0x00007ff520f95000)
ldd /opt/intel/compilers_and_libraries_2018.1.163/linux/mpi/intel64/bin/mpiexec => (0x00007ffc95fe2000)
/preload (0x00007f31935af000) => /lib64/ (0x00007f31933ab000) => /lib64/ (0x00007f319318f000) => /lib64/ (0x00007f3192e8d000) => /lib64/ (0x00007f3192c77000) => /lib64/ (0x00007f31928aa000)
/lib64/ (0x00007f31937b2000)

How can I fix the issue?

Thank you in advance!

Attached File
energy_mutabinds_lb38p.txt  (340 downloads)
Attached File
energy.test.txt  (360 downloads)
Posted By: rmv Re: Cannot work in parallel with mpi - 08/21/20 12:45 PM
When the PRNLEV command is used in parallel, you MUST use the NODE option to restrict the scope; try


instead of PRNLEV 0
Posted By: lennart Re: Cannot work in parallel with mpi - 08/21/20 09:13 PM
PBEQ does not run in parallel
© CHARMM forums